You are here

Burned my VESC 6 MKV. Wrong polarity

5 posts / 0 new
Last post
okhsunrog
Offline
Last seen: 1 month 3 weeks ago
VESC Free
Joined: 2022-02-18 15:25
Posts: 3
Burned my VESC 6 MKV. Wrong polarity

<p>It's the first time I do such a stupid thing. I connected - to + and + to -. It was really late and I wasn't really careful soldering XT-90 connectors. So there was a loud sound and XT-90 connector turned black. I guess it was connected less than for a 1 second. When I connected it the right way afterwards, it didn't turn on. No LEDs were on. What can I do? Can I repair it? Is it worth fixing? It was a really expensive thing for me to buy, like a half of my salary and now I'm really worried. Can you help me, please?</p>

okhsunrog
Offline
Last seen: 1 month 3 weeks ago
VESC Free
Joined: 2022-02-18 15:25
Posts: 3

It works. I forgot to press the button after rewiring

frank
Offline
Last seen: 16 hours 6 min ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 802

Typically they don't survive this easily.... If the VESC 6 still works, you are lucky.

okhsunrog
Offline
Last seen: 1 month 3 weeks ago
VESC Free
Joined: 2022-02-18 15:25
Posts: 3

Maybe that's because it was connected for less a second and it has a button to turn it on. No idea

frank
Offline
Last seen: 16 hours 6 min ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 802

A second is more than enough! If it still works, you are lucky!!!