You are here

Importance of the MK version and Determining the MK version of the VESC

9 posts / 0 new
Last post
alexantosh
Offline
Last seen: 1 hour 41 min ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 13
Importance of the MK version and Determining the MK version of the VESC

Hello. I have a VESC6 based ESC. It is VESC tool compatible. I want to flash the VESC_servoout.bin firmware onto the ESC. Now I have the following two concerns stemming from the fact that its only till VESC tool 2.03 that the VESC_servoout.bin firmware is provided. I managed to find the repo that contains these firmware bin files  but there are different versions depending on the VESC's MK numbers (III, IV, V ...).

1. Is there a way that I can determine the MK number of the VESC that my ESC is using?

2. Is flashing the ESC with a different MK numbered VESC_servo_out.bin firmware from the one the VESC is actually using fatal to the VESC? or will it just not work? Depending on the risk. I will hope there is a way to determine the Mk number. If not then I will try them out one by one.

Thanks for your guidance.

frank
Offline
Last seen: 1 hour 15 min ago
VESC BronzeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 501

The manufacturer should be able to give you the Information. What FW does VESC-Tool suggest? That actually depends on what VESC-Tool finds on the device.

alexantosh
Offline
Last seen: 1 hour 41 min ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 13

I have a FSESC6.6. The manufacturer is Flipsky. I contacted them and they said they don't have and don't know the MK version number. I installed the vesc-tool version 2.03 because it comes with the VESC_servoout.bin firmware which i need for my application. The tool says that there are updates for the firmware but he current one is 'mostly' compatible. Thats why i decided to first ask for guidance before proceeding. Should i install the latest VESC tool, look for its suggestion and then download a corresponding VESC_servoout.bin? Is this a safer approach?

Thank you a lot by the way.

alexantosh
Offline
Last seen: 1 hour 41 min ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 13

Checking the FW, HW specs after installing the most recent vesc tool and connecting the FSESC, I can see that it has the following:

FW: 4.1, HW: 60

And the supported firmware loaded being: 4.1. Is it safe to assume that this falls under the MK IV category? Also, is it ok to upgrade the firmware because the VESC tool still issues the same warning. that:

"The connected VESC has old but mostly supported firmware ..."

frank
Offline
Last seen: 1 hour 15 min ago
VESC BronzeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 501

IF it pops as HW60, then it is the old HW 60 design and not MK 3-5. MK3 had a different IMU, MK4 hibernation, MK5 has additional phase filtering.

alexantosh
Offline
Last seen: 1 hour 41 min ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 13

ok, now am a bit confused. Indeed it does pop as HW 60. So whats the  compatible VESC_servoout.bin version to this hardware if it is not MKIII, MKIV or MKV?

Also as update, I upgraded the firmware the the default suggested firmware for now, just to make sure nothing is out of place. So as of now it is showing:

FW: 5.2, HW: 60.

What i need is the version of VESC_servoout.bin firmware that is compatible to this ESC. Thank you very very much frank.

 

frank
Offline
Last seen: 1 hour 15 min ago
VESC BronzeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 501

You need to ask the manufacturer. They designed it. This is the repository for the standard FW supplied by Vedder: https://github.com/vedderb/vesc_tool/tree/master/res/firmwares

alexantosh
Offline
Last seen: 1 hour 41 min ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 13

ok thanks frank.

alexantosh
Offline
Last seen: 1 hour 41 min ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 13

Hello frank, according to the manufacturer, they used the 60 from the standard repository. Just 60. how do i go about compiling, if necessary, the VESC_servoout.bin for that FW? Image below shows it. So how do i go about obtaining or compiling the compatible VESC_servoout.bin for this?

FW.png