You are here

Flipsky ESC 6.6 - How to Compile? [fixed]

4 posts / 0 new
Last post
hoeken
Offline
Last seen: 8 months 3 weeks ago
Joined: 2021-06-12 01:50
Posts: 8
Flipsky ESC 6.6 - How to Compile? [fixed]

I'd like to try a few changes to the firmware, and I am using a Flipsky FSESC 6.6.  It showed up in VESC Tool as hardware '60' and works fine with the default firmwares.  I've checked out vedderb/bldc from github, updated it to the regular hw60, and then compiled it.  It uploads to the board fine, but it doesn't work.  Is there something I'm missing here?  I'd like to figure out the workflow to get a firmware exactly like the existing v5.2 release before trying anything fancy.  Here is my git diff from the master branch of vedderb/bldc.  Thanks in advance for any help!

diff --git a/conf_general.h b/conf_general.h
index 01287aa..dd76a72 100644
--- a/conf_general.h
+++ b/conf_general.h
@@ -72,7 +72,7 @@
 // Mark3 version of HW60 with power switch and separate NRF UART.
 //#define HW60_IS_MK3
 //#define HW60_IS_MK4
-#define HW60_IS_MK5
+//#define HW60_IS_MK5
 
 #define HW_SOURCE "hw_60.c"
 #define HW_HEADER "hw_60.h"

 

TechAUmNu
Offline
Last seen: 5 days 8 hours ago
VESC Free
Joined: 2017-09-22 01:27
Posts: 571

probably not based on MK5, it will be based on the released schematics so try MK3 instead.

hoeken
Offline
Last seen: 8 months 3 weeks ago
Joined: 2021-06-12 01:50
Posts: 8

Well, its not MK3 and its not MK5 - both of those bricked the VESC.  Serial port just kept connecting and disconnecting on a loop.  Really handy that Ben added the ability to SWD prog a VESC with another VESC.  I re-uploaded the 60 firmware and it works properly again.

When the units arrived, they have the '60' hardware string, and that is the firmware included with VESC Tool that works on them.

I'm wondering if it is something in my toolchain...... I did some googling and found this thread:  https://vesc-project.com/node/2793

I uninstalled the newer version of the arm tools and installed the older version and that seems to have fixed the problems. 

alexantosh
Offline
Last seen: 3 months 21 hours ago
VESC Free
Joined: 2021-04-05 18:05
Posts: 24

Hello, what hardware version/board did you choose?

it surely is not one of:

//#define HW60_IS_MK3
//#define HW60_IS_MK4
//#define HW60_IS_MK5

is it this one? I also need to recompile the firmware for my app with different servo settings.

// Benjamins first HW60 PCB with PB5 and PB6 swapped
#define HW60_VEDDER_FIRST_PCB