You are here

fsesc 4.20 CAN bus not detecting

4 posts / 0 new
Last post
LeonD
Offline
Last seen: 1 year 8 months ago
Joined: 2020-07-22 15:25
Posts: 3
fsesc 4.20 CAN bus not detecting

problems;

1) vesc tool dus not recognize second (CAN) vesc 

2) motors not starting equal.

3) not able to connect to second vesc

 

video about problem; https://youtu.be/0If_Vksw65c

i now that both te motors work correctly.

Schermopname (534).png

Schermopname (533).png

 

i am contacting the seller about it and flipsky but they do not respond very fast so i thought i would ask here.

( i don't now if it is a hardware problem or software so i pud it in the "vesc tool" forum)

thanks in advanced 

 

 

spacewalker
Offline
Last seen: 2 months 1 week ago
VESC FreeVESC Platinum
Joined: 2020-06-10 12:30
Posts: 29

what I think you not enable  CAN  on 2nd vesc, that is why  from main VESC  you can not see   2nd one 

Martin

LeonD
Offline
Last seen: 1 year 8 months ago
Joined: 2020-07-22 15:25
Posts: 3

thanks for the reply,

the problem is that i am not able to connect my "slave" vesc to my computer (the fsesc 4.20 is 1 unit). i get a warning; "invalid serial port:\\.\com6" 

i do not get this warning on the master vesc.

MartyMcFlyFord
MartyMcFlyFord's picture
Offline
Last seen: 5 months 1 week ago
Joined: 2022-05-20 14:15
Posts: 3

Ok so I had same issue, turn off esc, switched Filpsk mother board to singe motor connected backup up then re uploaded firmware and Bootloader waited then unplugged flicked switch on motherboard and now I can see both motors... Now onto why I cannot change the brakes on my puc (too sharp) :)

 

^^^me^^^