You are here

Vesc tool 1.26.. issue with firmware updates?

3 posts / 0 new
Last post
beetbocks
Offline
Last seen: 7 months 2 weeks ago
Joined: 2018-10-18 23:04
Posts: 3
Vesc tool 1.26.. issue with firmware updates?

Hi Guys

Ive just updated my Android vesc tool to 1.26 and now i cannot update firmware by Bluetooth.. it starts to buffer then the app just closes down..

I had to update firmware by usb..

Any one else have this issue?

Stupidspencer
Stupidspencer's picture
Offline
Last seen: 1 year 10 months ago
Joined: 2019-06-20 00:06
Posts: 32

Not really sure what happened at the moment, but my bluetooth isn't working at all now since the update.  With FW3.62 I had my board working perfectly. Upgraded to 3.63 and lost reverse. Firmware 3.64 was released only something like 2 weeks later, and I updated hoping to get reverse back.  I did get reverse back, but I got all kinds of other issues now.

My first problem was that my previous configuration was reset, so I had to re-run motor detection. Detection was successful but it showed that one of my motors only drew 50A when it was previously detected (several times) around 91A. The motor on the other VESC was reported as expected: 91A.

And upon completing input setup AGAIN *sarcasm* I found that the motor in question did not run correctly. Sh!t, power off.

Next time I powered on, no bluetooth. And the LED on the BT module not lighting.

So I guess I will try again with USB and PC and hope it fixes something. frown

Stupidspencer
Stupidspencer's picture
Offline
Last seen: 1 year 10 months ago
Joined: 2019-06-20 00:06
Posts: 32

I updated to FW 3.65 via USB/PC and got full functionality back. With 3.64, it seems CAN was broken so I had to update each VESC independently via USB. But I have bluetooth, reverse, and all appears to be working properly again. The motor that was detected at 50A is now being detected at 89A:  close enough!  I think the low number was a result of the CAN communication not working right.   smiley