You are here

Serial port errors with VESC Tool 3.00 and Flipsky FSESC 7550

2 posts / 0 new
Last post
mckenzie.keith
Offline
Last seen: 2 months 3 weeks ago
VESC Free
Joined: 2021-12-18 00:31
Posts: 5
Serial port errors with VESC Tool 3.00 and Flipsky FSESC 7550

For a while VESC Tool communicated with my FSESC 7550 perfectly. But at some point after two days of poking around, I started seeing serial errors. Debug console excerpt follows.

2022-01-05 17:11:36: VESC® Tool 3.00 started
2022-01-05 17:11:37: Status: Not connected
2022-01-05 17:14:03: Status: Connected (serial) to COM8
2022-01-05 17:14:04: Status: VESC Firmware Version 5.2, Hardware: 75_300, UUID: 21 00 47 00 15 50 31 57 39 38 34 20
2022-01-05 17:14:04: Status: MC configuration updated
2022-01-05 17:14:04: Status: App configuration updated
2022-01-05 17:14:12: Status: Serial port error: The I/O operation has been aborted because of either a thread exit or an application request.
2022-01-05 17:14:15: Status: Not connected

I can't go more than maybe 10 seconds without seeing this error, so it is hard to get anything done.

I have an STLink V2 and use it all the time to load FW. So if reflashing this thing could help, I can try connecting to the SWD header on the FSESC 7550.

mckenzie.keith
Offline
Last seen: 2 months 3 weeks ago
VESC Free
Joined: 2021-12-18 00:31
Posts: 5

Interesting. I was using a flipsky display also. I tried disconnecting the display from the FSESC 7550, and in that configuration VESC Tool can talk to the FSESC 7550 without any serial port errors. So something about the display is causing problems, I guess.