You are here

4.12 HK VESC - Static blue LED and no usb Connection, HELP!!

6 posts / 0 new
Last post
plot1992
Offline
Last seen: 2 years 5 months ago
Joined: 2018-07-28 09:22
Posts: 2
4.12 HK VESC - Static blue LED and no usb Connection, HELP!!

Hey community,

I actually am really frustrated now, short overview of what happened:

  • got VESC (4.12 from HK) after an Car-ESC
  • set it up on a friends PC using BLDC-Tool 
  • after 50km driving wanted to edit settings - downloaded VESC-Tool
  • did a firmware upgrade cause it said so (for 4.12 HW)
  • NO USB connection between PC and VESC possible anymore (static blue LED)
  • flashed bootloader with STLINKV2
  • VESC still cannot connect to PC (even installed STM32 drivers for windows again, allthough they worked
    previously)
  • no usb connection between vesc and pc

I am really down right now, don’t have the money to get another VESC. Can someone help? or help me troubleshoot this.

Best regards, Thomas

EDIT: USB-Cable is tested

Danny Bokma
Offline
Last seen: 3 days 11 hours ago
VESC Original
Joined: 2017-05-24 12:11
Posts: 53

Hi,

You wont be able to communicate with the bootloader directly. You will need to flash the main esc firmware AND bootloader.

Please erase the full chip, then flash bootloader, then the main firmware (make sure to disable erase flash during the flashing of the application and firmware).

Good luck!

plot1992
Offline
Last seen: 2 years 5 months ago
Joined: 2018-07-28 09:22
Posts: 2

Thanks a lot man, got it working! You are the best <3

Frazatto
Frazatto's picture
Offline
Last seen: 1 year 1 month ago
Joined: 2018-06-27 15:33
Posts: 18

Hello, if I may ask, how do you connect the stlink to the VESC?
I'm in a similar situation but can't figure it out which pin connects to what.

Frazatto
Frazatto's picture
Offline
Last seen: 1 year 1 month ago
Joined: 2018-06-27 15:33
Posts: 18

Ok, the manufacture sent me the correct diagrams, now everything makes sense!
Thanks anyway.

Frazatto
Frazatto's picture
Offline
Last seen: 1 year 1 month ago
Joined: 2018-06-27 15:33
Posts: 18

It seams now I have this exact problem.
But I don't understand how to execute the procedure you describe.

STlink is working 100%, I'm following the original instructions (http://vedder.se/2015/01/vesc-open-source-esc/) and still no usb connection.
How do I erase the full chip?
How do I know flashing the firmware is not erasing the bootloader?
Shouldn't I flash the firmware before the bootloader???