You are here

VESC 100/250 Bluetooth not showing up

3 posts / 0 new
Last post
JumpinJackFlash
Offline
Last seen: 1 year 9 months ago
VESC Original
Joined: 2021-08-27 08:08
Posts: 2
VESC 100/250 Bluetooth not showing up

Hi,

Hoping someone can help me. I have only just started playing with the VESC. I can connect fine via USB to my laptop and have updated to the 5.3 firmware. No matter what I try though I cannot read the Bluetooth signal and I was under the impression that BT is native on this VESC unit? 

I was expecting to at least read a BT signal but I cannot and I have tried multiple phones. I have moved to an area miles away from any possible interference. 

Has anyone experienced this and what did you do to fix it. Is is possible I have a duff bluetooth module? 

Many thanks in advance.

John

frank
Offline
Last seen: 1 week 1 day ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC PlatinumVESC Silver
Joined: 2016-12-27 20:19
Posts: 847

BT will only work under Linux. Windows is not supported. You can also connect to your phone and build a TCP bridge to your desktop. Phone and computer need to be in the same network.

The Phone App has a section in the lower part of the first page. VESC-Tool has the TCP option in the CONNECTIONS menu. You need to enter the IP shown in the App and click connect.

JumpinJackFlash
Offline
Last seen: 1 year 9 months ago
VESC Original
Joined: 2021-08-27 08:08
Posts: 2

Thanks for the reply Frank, have got connected on the phone. I needed to erase and re upload the firmware for the BT module.

JumpinJackFlash