You are here

Calibration ERROR with TLE5012B Magnetic encoder in ABI mode

3 posts / 0 new
Last post
cejota
Offline
Last seen: 3 months 3 weeks ago
VESC Free
Joined: 2022-01-24 22:55
Posts: 1
Calibration ERROR with TLE5012B Magnetic encoder in ABI mode

Hello everyone,
I purchased the flipsky 75_100V201 model (white circuit board) *tested with 5.2 and 5.3 fw

and a magnetic encoder (TLE5012BE100) configured factory with 4096 pulses (16384cpr) *tested in stm32f704 with controller firmware and works perfectly

I'm using it in ABI mode, (ABZ output) everything is connected and isolated perfectly apparently, but when I try to calibrate it, the motor goes around a few times with small "jumps" in both directions and stops at that, the calibration doesn't complete, no the result in the fields of offset and ratio, and the board practically "stuck" in the calibration because the led persists in remaining green.

-PRINT OF FOC ENCODER TAB:

ENCODER CONFIG.png

-PRINT OF GERENAL CONFIG:

GERENAL ENCODER CONFIG.png

-PRINT OF REALTIME DATA ENCODER: *the waves jump from 0 and go straight to 360 degrees after moving the motor shaft in one direction*

REALTIME DATA WITH ENCODER.png

1- maybe I'm configuring wrong in vesctool?
2- or maybe I need to change something in the firmware to work with this encoder model?

any help/tip is welcome. unfortunately I don't have the financial means to buy another board or even a better version, I saved up a few months to buy it. sad

XieMaster
Offline
Last seen: 2 weeks 1 day ago
VESC Free
Joined: 2021-05-12 09:34
Posts: 3

你好!

我也遇到了这个问题,很开心的是我找到了解决方法。

我和你一样用 VESC Tool 打开Encoder界面,发现了数据跳动,用示波器测试正常所以觉得是线序出错了。

你可以这样测试一下:

VESC HALL A    <---->    Encoder I

VESC HALL B    <---->    Encoder B

VESC HALL C    <---->    Encoder A

重点在 VESC HALL A 是接 Encoder I,另外两个正交脉冲引脚可以随便接。

如果还是不行的话试试换一下线序。

不过我现在还遇到了新的问题,就是编码器校准的 Encoder Offerset 、Ratio

祝你好运!

 

VESC XieMaster

XieMaster
Offline
Last seen: 2 weeks 1 day ago
VESC Free
Joined: 2021-05-12 09:34
Posts: 3

你好!

经过这几天的测试,已经发现了根本问题。

Flipsky 75V100A 和 75V200A 驱动器 HALL1 和 HALL3 都是反的。

 

连接TLE5012B编码器ABI接口:

因为编码器I输出的脉宽比较窄,发现VESC没有检测到。

建议换其他ABI编码器或者用AS5047

同时正确的连接方式为:

Flipsky VESC HALL 1 <----> Encoder I

Flipsky VESC HALL 2 <----> Encoder B

Flipsky VESC HALL 3 <----> Encoder A

 

我也测试了AS5047P编码器,SPI接口通讯,测试工作良好。(需要修改VESC的HALL滤波电路)

同时正确的连接方式:

Flipsky VESC HALL 1 -> CSn

Flipsky VESC HALL 2 -> MISO

Flipsky VESC HALL 3 -> SCK

 

可以测试一下,祝你好运!

VESC XieMaster