You are here

E-bike with vesc board

6 posts / 0 new
Last post
tailele
Offline
Last seen: 1 day 14 hours ago
VESC Free
Joined: 2020-09-13 16:32
Posts: 6
E-bike with vesc board

Good morning Boys, i already asked in general forum, but i didn t recive any information, maybe It was in a wrong section.

I changed the old esc with a new vesc board in mu ebike. The battery Is a 16s10p 26000mah.

So my problem Is that i don t have torque when i push the Throttle. The maximum velocity Is the same that i had with the old esc . The old esc was a 60v and 40 amps. The new esc Is 72v 130 amps in continuos .

The motor Is a 1300w continuos Power and 1800w peack Power 60v sensorless. 

In vesc tool I tried with autodectection , i set medium motor and the vesc tool gives me 50 amps as max current , i think that this value Is right with the motor spec.

Now, when i push the Throttle the motor tries to start , and gives to me some punchs , but It seems to haven t the sufficent torque. Instead if i stand up the tyre , It turns without problem. Is It possible to increase the torque to return to the old acceleration? Thanks a lot

TheFallen
Offline
Last seen: 13 hours 29 min ago
VESC FreeVESC Original
Joined: 2017-09-11 11:46
Posts: 172

This is a quiet forum, if you've not received an answer is possible no one on here knows. Sometimes updating with more information can help, e.g. pictures, VESC settings/logs.

What VESC are you using?
Could you show a picture of your setup?

tailele
Offline
Last seen: 1 day 14 hours ago
VESC Free
Joined: 2020-09-13 16:32
Posts: 6

Sorry, i think that it was in a wrong section. Anyway , here i upload my settings

https://imgur.com/a/QUAYGk2

The board is a ubox from spintend. The board if i remember is a 100amps in continuos. Here there is link:

https://spintend.com/products/75v-200a-dual-motor-controller-ubox-based-...

skyline1970
Offline
Last seen: 1 day 14 hours ago
VESC Free
Joined: 2017-09-07 22:28
Posts: 26

At app. settings control type should be selected as current.

tailele
Offline
Last seen: 1 day 14 hours ago
VESC Free
Joined: 2020-09-13 16:32
Posts: 6

Sorry i don t understand.... I don t find that section...thanks a lot

skyline1970
Offline
Last seen: 1 day 14 hours ago
VESC Free
Joined: 2017-09-07 22:28
Posts: 26

App Settings, -> ADC, -> General , -> Control type usually duty cycle is selected, here Current modes could be selected. This mode is torque based control, that it provides more torque at starting, and wants to reach max. speed value.

By the way, the motor should have been recognized by the controller, in a right way. Because, wrong detected usage may not be efficient and proper. Maybe, your motor had been detected as field-weakened, that it can very high rpm values, however, no powerful as it must have. If datasheet of motor exist, you could use the values specified on it, or at least compare detected values by the datasheet, first. At least R & L values should be truly specified. Then, Lambda should be known and Observer gain could be trimmed.