You are here

75/300 NRF Pairing

4 posts / 0 new
Last post
eptv
Offline
Last seen: 3 days 21 hours ago
VESC Original
Joined: 2018-10-21 21:20
Posts: 6
75/300 NRF Pairing

Hello All,

 

I have 75/300 with NRF Dongle (https://www.trampaboards.com/vesc-connect-nrf-wireless-dongle-p-26767.html)

 

I connected dongle with serial COMM cable and Bluetooth is working.

 

Also I have Vesc WAND remote. And pairing is not working. I switch on WAND but seconds just going from 10 to 0.

 

Could you point the right way to pair WAND?

frank
Offline
Last seen: 1 day 12 hours ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 332

The 75/300 has a built in dongle already. If you connect a second dongle, this donge can't work properly.

If you want to use an external dongle ( eg. for better connectivity and dongle placement) you need to disable the internal dongle by erasing the FW.

The 75/300 has two SWD ports as you can see.

You need to connect the SWD port to the SWD port of the built in NRF (IO and CLK only).

Then connect to VESC-Tool and open SWD PROG.

Click connect and then it will find the built in NRF chip. Once it found it, you click on erase and disconnect.

eptv
Offline
Last seen: 3 days 21 hours ago
VESC Original
Joined: 2018-10-21 21:20
Posts: 6

I'd like to use internal dongle. I can connect BLE using vesc_tool without issues. But can't pair WAND. Paring process just counting down 10 seconds. I switch on WAND during this count down. But nothing happens.

frank
Offline
Last seen: 1 day 12 hours ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 332

You might need to update the FW on the internal dongle!

Locate the NRF and SWD Port, bridge CLK to CLK and IO to IO and GND to GND. The Wand has a suitable Cable coming with it. You just need to remove the 3 PIN male connector from the one side of the cable.

Then connect to VESC via USB and desktop VESC-Tool.

Open SWD PROG menu, click CONNECT (not CONNECTt NRF 5X).

After connection select VESC BLE Builtin and hit erase and uplaod. After upload click disconnect.

Remove cables before running a motor!!!!