You are here

Update fail from FW3.58 to 3.61

8 posts / 0 new
Last post
sachs2019
Offline
Last seen: 2 years 9 months ago
Joined: 2019-09-09 09:21
Posts: 2
Update fail from FW3.58 to 3.61

Hi,

When I connect the VESC-6 to vesc-tool I am informed that the VESC has too old firmware and that the tool will only allow firmware update.

When I go to the firmware page I see Hardware version 60 with firmware VESC_default.bin in the two Included Files panes. I go to apply the firmware which it uploads to the device, taking less than 10 seconds and then the VESC disconnects with only the blue power light lit on the VESC. The tool claims fw upload done.

After I power cycle the VESC and try to connect, I am told the firmware is still too old and it seems the firmware update did not apply.

In each case, when I go to the firmware page the connected VESC firmware is 3.58 and the tool claims it only supports 3.61.

I have tried in Windows

I see other firmwares in the non-default firmwares view but none of them will update the firmware version on the connected VESC.

The tool version is 1.19.

Thanks,

 

TechAUmNu
Offline
Last seen: 3 weeks 6 days ago
VESC Free
Joined: 2017-09-22 01:27
Posts: 571

upload the bootloader first (only do it once though or you will be stuck)

then update the firmware.

sachs2019
Offline
Last seen: 2 years 9 months ago
Joined: 2019-09-09 09:21
Posts: 2

I do it like this, but it did not work!

the light is flashing at the FSESC and after 10s, I want to connect again and the warning: 'too old firmware...' come again.

frank
Offline
Last seen: 5 days 1 hour ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 725

SWD Prog the thing. Benjamin has a video about SWD Prog  on his YouTube channel. 

Or get yourself a ST-LINK V2 from ebay. 

If you search for ST-link on this forum you will find the answers you need to know. 

 

Stupidspencer
Stupidspencer's picture
Offline
Last seen: 1 year 3 months ago
Joined: 2019-06-20 00:06
Posts: 32

I believe sachs2019 is experiencing an issue that I have had everytime firmware is updated. I am running a similar setup as him with 2 VESC6s connected over CANbus. I don't know if this is a problem with the Windows version of VESC tool, because I have only been using the Android version with the bluetooth link ever since I received my VESCs.

It seems that this issue shows up when CAN forwarding is enabled, and I think its a bug. If I try to run motor detection when CAN forwarding is enabled, I get several error messages at the moment that the detection would normally try to start the motors. The errors are: "The connected VESC has too old firmware", and "No response from VESC at address XX. Make sure it is connected".  Please note that is probably not the exact wording, but I don't want to re-create the problem to quote the messages perfectly because every time it happens, I'm scared that I might not be able to ride my board until another firmware is released if I can't work through it. When I get the error, the bluetooth link disconnects.

I have been able to successfully update the firmware on the bluetooth connected controller and the one connected through CANbus simultaneously twice now. Both times gave me trouble. Apparently CAN forwarding should always just be left turned off. If there is another controller on the CANbus, the motor detection will run on it and firmware updates will go to it as long as its physically connected.

However, I have noticed that my RT data is only that of the bluetooth connected controller. When I manually turn my board's left wheel (the one connected through CANbus), I get no RT data response. But my traction control works, and the PPM signal is passed through, so I know the two are communicating.

timothy.burkhard
Offline
Last seen: 2 years 8 months ago
Joined: 2019-10-19 00:17
Posts: 1

I have the same issue, I believe. I followed the setup directions, but the firmware does not update. No errors given on update. 

When I click the firmware menu, here's what I see that indicates to me that the firmware is not updated:

VESC Firmware, Hardware and UUID Supported Firmwares

FW: 3.58, Hw: 410

55 00 2E 00 07 50 4B 47 57 33 31 20

Paired: false

3.62

I "Upload" the firmware per the instructions, and everything goes OK with no errors. But I continue to get the "too old firmware" error, and the table shown above remains unchanged.

The hardware I'm using:

diyelectricskateboard[dot]com/products/electric-skateboard-motor-6380-170kv

diyelectricskateboard[dot]com/products/torque-esc-bldc-electronic-speed-controller

Thank you.

frank
Offline
Last seen: 5 days 1 hour ago
VESC BronzeVESC FreeVESC GoldVESC OriginalVESC Silver
Joined: 2016-12-27 20:19
Posts: 725

Missing or messed up Bootloader.  

Recover it using the ST-V2 or via a second VESC using SWD Prog. 

https://vesc-project.com/comment/225#comment-225

And for SWD Prog please watch Benjamin Vedder  YouTube channel. 

 

 

AlmaRaposa
Offline
Last seen: 1 year 3 months ago
Joined: 2021-02-25 13:54
Posts: 1

The projects fit the entitled items for the citizens. Each conception of the essay and official site for the compact augment for the field. The team is plucked for the true way for the better for the fieldwork for the citizens.