You are here

Firmware for 4.xx VESC in new VESC Tool?

10 posts / 0 new
Last post
sl33py
sl33py's picture
Offline
Last seen: 2 years 10 months ago
VESC Original
Joined: 2017-05-24 12:32
Posts: 28
Firmware for 4.xx VESC in new VESC Tool?

I just want to check in and start a thread to check status and get updates on ETA?

I have 2 VESC Six, and 8+ 4.xx VESC's. Would love to have one system to configure them all!

We had an initial ETA of 1 week before 4.xx firmware was released for new VESC Tool. It's been 2-3 weeks now i believe and want to see if we have an updated timeframe?

I know you all are busy, and hope Benjamin is healing up fully from his injury!

Thx All!

benjamin
Offline
Last seen: 3 hours 20 min ago
Joined: 2016-12-26 15:20
Posts: 377

I have been working on it and I just need to test the paypal checkout for the versions with donations a bit more. It should be ready in the next days.

sl33py
sl33py's picture
Offline
Last seen: 2 years 10 months ago
VESC Original
Joined: 2017-05-24 12:32
Posts: 28

Great news Benjamin! Happy to chip in a donation for the extra feature availability.

Will this work for the older 4.7 VESC's? I'm trying to re-use my oldest VESCs for a gift/build for my brother (so we can ride together).

Appreciate the update, and know you guys are all super busy. Hope you are healing up fully and will be riding again soon (with new tires maybe?...) ; )

Thanks!

benjamin
Offline
Last seen: 3 hours 20 min ago
Joined: 2016-12-26 15:20
Posts: 377

It will work with 4.7 as well. I'm using a 4.7 on my ebike.

The board already has new tyres, I'm just waiting for my foot to heal :-)

sl33py
sl33py's picture
Offline
Last seen: 2 years 10 months ago
VESC Original
Joined: 2017-05-24 12:32
Posts: 28

Soooo... Let's just say i was excited after reading hexacopter's initial thread w/ 4.xx support (seems he accidentally got it). And so i followed the steps, too excited to pay attention - and flashed v6 onto a 4.xx VESC.

Now that the correct 4.xx fw is out, it still only sees v6 firmwares and won't let me flash v4.xx fw.

STLink able to fix, or steps in VESC tool to fix over USB?

Noob mistake...

I've configured 3 VESC's this week since released and LOVE the new interface!!!

benjamin
Offline
Last seen: 3 hours 20 min ago
Joined: 2016-12-26 15:20
Posts: 377

You can use the custom file tab and flash the correct firmware if you have the file. I can post a link when I get home. Alternatively you can revert back to 2.18 using the custom file tab and then flash the correct firmware.

sl33py
sl33py's picture
Offline
Last seen: 2 years 10 months ago
VESC Original
Joined: 2017-05-24 12:32
Posts: 28

Thank you Ben!

I will try that when i get home. I'm rebuilding my STLink as well since i've somehow managed to lose the one i built a few years ago... Just in case needed.

Can you clarify for a noob the purpose of all the random firmwares listed? default is default, but 33k, servoout, no_hw_limits, and ws2811?

Just curious and if i need to browse for these .bin files - location for custom file selection?

Thanks!!

sl33py
sl33py's picture
Offline
Last seen: 2 years 10 months ago
VESC Original
Joined: 2017-05-24 12:32
Posts: 28

Hey Ben - I looked last night when i got home and couldn't find any .bin files to point the custom file path. Are you able to provide a location with those files so i can select them?

Similarly i don't see a 2.18 file path to select/flash to then re-use the new 3.2x for this old 4.7 hw.

Appreciate your help with this!

benjamin
Offline
Last seen: 3 hours 20 min ago
Joined: 2016-12-26 15:20
Posts: 377

Here's a link to the latest firmware for HW4.7:

http://home.vedder.se/tmp2/VESC_default_4_7.bin

you should be able to flash it by selecting it from the custom file tab.

sl33py
sl33py's picture
Offline
Last seen: 2 years 10 months ago
VESC Original
Joined: 2017-05-24 12:32
Posts: 28

Thanks! I'll update when i get home tonight.

I will earn many brownie points with the GF when she can ride again!

EDIT - that did the trick! Thank you Ben!!

She is riding again! Upgraded her to a new motor before my mistake. Now running 192kv 8s FOC Sensored! Sooooo smooth!