You are here

Flipsky FSESC 4.20, can it work with an AB encoder with no Index? Having a lot of trouble with low speed torque and speed contro

1 post / 0 new
PaulMakesThings
Offline
Last seen: 4 months 1 day ago
VESC Free
Joined: 2021-10-13 08:51
Posts: 4
Flipsky FSESC 4.20, can it work with an AB encoder with no Index? Having a lot of trouble with low speed torque and speed contro

The motors are these https://skysedge.com/robotics/robowheel170/index.html

Approximate diameter of rolling surface: 170mm No gears; completely silent 27 poles and 1.7Ω winding resistance for low cogging Integrated 3200 PPR quadrature encoder Operating voltage: 7-42V

So this driver uses the same input for Hall or the encoder. It also has a mode for an ABI encoder, but none for one with no index.

I'm trying to figure out the best way to get it to run smoothly at very low speed. It'll be on a 24V LiFePo4 battery.

I am trying to use the FOC. Which I think requires the encoder. It seems to work on with just AB. But at very low speed it is also super weak. It tends to bumble a bit at the start before it gets rolling. At over about 4 mph it has plenty of torque.

I am also trying to use UART to control it, and it will move with a duty cycle or current command but not a speed command, is it possible that's because there is no index?

Would it work better maybe with the hall sensors? Is there possibly a way to use both?

Any suggestions for what settings I should look at to get the low speed operation to be smoother and higher torque?