You are here

FSESC 4.12 Power Issues

4 posts / 0 new
Last post
moneybags
Offline
Last seen: 8 months 3 weeks ago
Joined: 2020-03-31 04:29
Posts: 2
FSESC 4.12 Power Issues

I have 2 Flipsky FSESCs like the one seen in this picture. Yesterday, one of them was disconnected during a ride, and after re-connecting it to power, it won't power on. No LED lights, nothing. I probed the 5V rail and I'm getting 5.1V, but when I probe the 3.3V rails, I'm getting 0V. This leads me to believe that the DRV8302 chip is working as it should be. The VREG (579-TC2117-3.3VDBTR) on the back of the PCB is heating up.

I assume that once I replace the VREG, it should power right up and things will work as expected. But, in the case that it doesn't, I'm wondering if I should be keeping an eye out for any other components that could be causing the issue. Any help or insight is greatly appreciated.

Cheers! 

moneybags
Offline
Last seen: 8 months 3 weeks ago
Joined: 2020-03-31 04:29
Posts: 2

UPDATE: I learned that if a VESC 4.12 based ESC is disconnected from the battery during a ride, and you attempt to brake, regenerative braking will kill the ESC because the power has nowhere to go.

I began buzzing out the FSESC with a multimeter and realized there’s a short between the 3.3V rail and GND on the entire FSESC. I desoldered the VREG and the short remains. I’m waiting on a hot air reflow station to arrive in order to desolder the MCU. Once the MCU is removed, I’ll check on the short and report.

neo
Offline
Last seen: 7 months 7 hours ago
Joined: 2021-06-12 00:00
Posts: 18

Pop the two protection diodes (marked sl) off and re test

neo
Offline
Last seen: 7 months 7 hours ago
Joined: 2021-06-12 00:00
Posts: 18

sorry wrong board, it's late lol. But there may be a diode shortedand causing the issue